Marketing website is down

Incident Report for Mako Fintech

Postmortem

The problem seems to have stemmed from a problem similar to the one here https://discourse.webflow.com/t/error-525-ssl-handshake-failed/73756/5

We had webflow provision an SSL certificate for us, and then stopped pointing that domain at webflow so they couldn’t renew it. We actually don’t need their SSL certificate, so we turned off SSL for our website in webflow and are handling it through our cloudfront distribution.

We have now turned off SSL settings in Webflow and are using our own SSL certificate, and are pointing to the SSL free Webflow proxy.

Posted Aug 25, 2021 - 15:43 EDT

Resolved

The makofintech.com marketing website was down from 2:50PM until 3:32PM due to an expired SSL certificate with our hosting provider. The incident is resolved and we now no longer depend on this provider's SSL configuration to encrypt our website.
Posted Aug 25, 2021 - 14:30 EDT